Replit seem to get stuck on running a code, but the code runs fine in other IDEs

Context/Question:
I am running 100 days of code, currently at 62 (although this problem has been randomly happening since I started using Replit)

Somewhat often, I run some code, it runs fine.
I then want to test another option/output in the code, and click run again, but it never starts, it just loads forever (at least 10 minutes+ and I don’t think it will suddenly work)

If I copy the code to another IDE it works fine (except in this specific case when using Replit DB of course)

I have tried removing all exit() and similar from the code (as someone suggested i another question) still doesnt work

Repl link/Link to where the bug appears:
https://replit.com/@tridoge/Day62100Days#main.py

Hi @tridoge , welcome to the forums!
Can you try entering kill 1 in theShell?
Hope this helps!

1 Like

Not really, I waited a long time and revisited the code hours later, it worked then

What does kill 1 do? Fresh start?

kill 1 forcibly shuts down the Repl and reboots it.

1 Like

Thanks @Firepup650 @NateDhaliwal !

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.