Replit (Python) pip disappeared

so around april, my replit stopped working (it had been fine for 3 months) because it gave the error selenium cant be found and doing pip commands give me this weird error. So how do I redownload pip in a nix environment. Editing replit.nix pkgs?

ImportError: /nix/store/...-glibc-2.33-117/lib/ undefined symbol: __libc_siglongjmp, version GLIBC_PRIVATE
1 Like

Are you using selenium for a proxy?

1 Like

i am not sure what you mean by proxy. i am using selenium to scrape and interact with the browser. but the real issue is that i cant do any pip commands

A proxy is essentially a server that provides a gateway between a user and the internet. So you can access websites through it without opening a single tab in your browser.

Could you try using beautifulsoup and webbrowser (other methods included) to do this instead and see if it works?

Strange. Have you tried using poetry?

1 Like

well i could, but the code previously worked before, so i’m more inclined to fix my pip. I think i’ll try making a new replit and copy everything over


Not yet because I thought I could get pip functioning with replit.nix or the nix env file. Also not sure yet how to use poetry file, but maybe ill look into it

@RikeshPatel3 can I get a link to your repl? Make sure it is public BTW, because I checked your profile, no project like this I can see.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.