Replit project will not stop

Problem description:
I was editing my .replit’s “run” command, and I made a mistake in the code. When I ran the code, it game me an error message, so I went and fixed the error. When I tried to stop the project, it simply would not stop. The only way to stop is to run it using the ?v=1 addition to the url of the repl and stopping it that way (from what I tried).

Expected behavior:
The replit should have stopped when I pressed “stop”.

Actual behavior:
The replit would imply say “stopping…” but never stop.

Steps to reproduce:

  1. Start a blank repl
  2. Create a file called main.sh
  3. Go to the file .replit and write: run = “bash main.sh”
  4. It will return an error, and stopping will not work.

Bug appears at this link:

Browser/OS/Device:
Browser is Google Chrome
OS is Chrome
Device is Lenovo Chromebook

try pressing ctrl c, ctrl d :smiley: . BTW welcome to community @sonicx180

2 Likes

I have tried this, but it does not work.

1 Like

mmm, share link please?

I have fixed this bug, and using public share will not replicate it because of how it works.
You can try using the process above.

1 Like

I see, please submit a feedback ticket for replit to resolve this :smiley:

Where do I do that? I would love to know so I can report this bug.

image
image
image
image
image

EDIT: I thuink, I’ve never actually submitted a ticvket

1 Like

This is where it brought me.

1 Like

oh… um I don’t know then sorry :sweat_smile:

1 Like

They’ve officially made the Ask Forum as the place to report bugs, I don’t think the old ticket system is active anymore, could be wrong.

2 Likes

O_O wow really that’s cool

1 Like

Here is a more detailed view of how this works:

Inside .replit:

run = [“bash main.sh”] #Normally it would be [“bash”,“main.sh”], so this is the code that starts the bug.
[nix]
channel = “stable-22_11”

Terminal Output:

unable to find executable exec: “bash main.sh”: executable file not found in $PATH

1 Like

If having run = ["bash main.sh"] causes the error, then why not just use run=["bash", "main.sh"]. I don’t know, but I’m guessing it’s because of the way run is used, I think the idea is that each element in the list is an argument/command, so having a command (bash) and an argument (main.sh) in the same element confuses Replit.

Yes, this is how I fixed it, but I was curious why this would affect how it ran