Replit not connecting to github

I have tried importing many diff github repos and they all fail. see screenshot
Problem description:
replit not connecting to github

Expected behavior:
add repo from github should work with a few clicks

Actual behavior:

Steps to reproduce:
1.create a new project
2. click Import from GitHub
3. paste in URL from github like: GitHub - LineIndent/Flet-Product-Design: Showcase a product/item using Flet UI.

Bug appears at this link:

Chrome is up to date

Version 109.0.5414.75 (Official Build) (64-bit)

1 Like

Have you tried hitting the “Connect GitHub to import your private repos.” link?
If you’re still stuck, try following the guide in our documentation

You can also try pasting the following into Console/Shell of the Repl:

git clone (GitHub repo url)

Hello, same problem here – I cannot connect an existing repository to my repl, it says there are no permissions even though I have granted everything I can do the github integration.

I have connected the github to public as well as private repos.

1 Like

Are you trying to connect your repl to a repository or import one?

I’m trying to connect my repl to my repository.

Can you send me the link to your Repl and repository you’re trying to connect?

specifically GitHub - betatester1024/BetaUtils: BetaUtilities for using WebSocket. to

Try creating a new Repl and hitting “Import from Github” instead of trying it from a raw repl.

Screen Shot 2023-02-24 at 9.29.19 AM

How can I transfer a database from one repl to another, though?

I might add that the github integration was working, but I renamed my repository and tried to reconnect the renamed repository, then it stopped working.

A replDB, or an sqlite-like database?

1 Like

it’s a replDB, and it’s got a lot of keys already in it.

You can use db.keys() to list all keys, iterate through them to copy the values, and export to a json file. Then you can loop through the keys and values there and apply it to your new repl.

Were you able to import the repository successfully?

1 Like

issue is, I can’t push my changes to the repository so the respository is old, should I still try to import it?

nope, doesn’t let me import.

So, uh, what happens now?

No, I was not able to import that repository successfully.

Hmm interesting. Click the “Connect GitHub to Import your private repos.” link below the input and try.