Replit.nix : inability to install the replit.nix package

I can’t seem to be able to install the .nix package on my replit hence I am unable to use it
Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:

code snippet

in future, ensure that you don’t try to type a command while you’re in the “command not installed” dialog. Remove line 5 of the replit.nix file.
To add packages through the Shell you can use sed:

sed -i '/  ];/i\    pkgs.vscode-extensions.b4dm4n.vscode-nixpkgs-fmt' replit.nix

What are you trying to achieve with this package?


Thanks Umar, I’d be sure to take note in the future.

The thing I am new to programming and I am still learning how to get by.

Actually, I am supposed to setup my Replit as my online environment so I can document my progress as I learn. I have used it the past but I notice I could not run my codes on it since the nix update, it keeps telling me to install it. I have tried your suggestion too and the attached picture what I got.

I thought to add the screenshot so you can see if I am doing it right or not.

Thank you again!

That command was intended to be run in the Shell, not added to the end of your replit.nix file. Try removing it from there, and then run it in Shell.

Additionally as that is a Python project, it seems it’s missing some core dependencies for the project to work properly.


Hello Firepup650,
Thanks for your response.

However, I have tried what you suggested also but I have made no headway still. And concerning “some core dependencies” you mentioned, I do not understand. I came to the forum to be pointed in the right directions and any will be much appreciated. Like I have mentioned before, I am new to this and I am still trying to navigate the path. See below the screenshot so you see the exact state of things.

oops. The command I sent was invalid. I’ve edited it now.
In your “CWW Assignment 4” repl you can restore the default .replit and replit.nix config: go on the files and click on the “History” button in the bottom then use the timeline at the bottom to select and restore a previous revision.

what are you trying to do when this happens, and what output do you get?