.replit 'hidden' list doesn't seem to be working

Problem description:
In my repl, some of the folders/files that are supposed to be hidden in the workspace show up anyway, even though their names are supposed to be hidden, as specified in .replit.

Expected behavior:
The ‘hidden’ list in .replit should hide the files in the filetree.

Actual behavior:
The files show up anyway.

Steps to reproduce:
I don’t know if it will work for others, but I just need to create a repl and these files will appear.

Bug appears at this link:
It isn’t really one fixed link, it’s more like all of my repls.

I’m using ChromeOS on a Chromebook.

Here’s a video recording of this problem (notice it’s not just one specific language where this problem persists):

(sorry for bad quality idk what happened)

Thank you!

What’s odd is that these files are actually hidden, but Replit for some reason defaults to them being shown (there is an option to show/hide them). I don’t remember this always being the case, but hiding them is easy. Simply click the options menu in Explorer and select “Hide hidden files”.

However, I do think this is a bug, or it’s just unintended. It should default to them being hidden, as their name suggests. It just causes unneeded confusion.

Ok, thanks 4 the fix!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.