".replit" file run = not working, replit won't run

I have the top of my .replit file configured as so:

run = ["npm run dev"]
And there are no conflicting run = assignments in the .replit file, but still, when I press the big green run button, the shell command I specified is not run. When I manually enter the command into the shell, it DOES run and work as intended. What is going on here?

I also tried run = ["npm", "run", "dev"] but that did not work either.
How do I get the .replit file to run the shell command I want when I run the repl?


run = "npm run dev"

Also make sure that the dev command exist in package.json

1 Like

alr checked on the pkg.json but the string is a good idea — trying it rn

unfortunately reformatting the shell command as a string literal doesn’t seem to have worked /: any other ideas?
for the sake of simplicity and narrowing down the actual solution i’m temporarily replacing the npm run dev with a simple ol echo hi.
On the array of strings, array of a string, and string, echo hi still does not work.

Did you give Replit some time to refresh?

I waited for the repl to save and successfully rerun before drawing conclusions, if that’s what you mean.
The official docs on the .replit file are here but I think they might be outdated because as you can see here: https://share.cleanshot.com/2WVLNL3X the page says that an array of strings: https://share.cleanshot.com/2WVLNL3X is the way to go. The same page also mentions:https://share.cleanshot.com/p7GH5p5s that an [Interpreter] tag will override it but removing the default [Interpreter] tag results in a nix error.

(I wish replit would let me embed images instead of having to use the bare links /: i apologize for the ugliness there)

I constructed an in-depth reply with many images and relevant links to explain what background information I have on the issue, but unfortunately, it was tagged for review because clearly discussing the .replit file is profane. I assume my reply will go live once someone at Replit can confirm I’m not a troll ): CleanShot 2023-02-25 at 01.45.00 · CleanShot Cloud

It happens when the system thinks you are a spammer or a bot. It happened to me in my first time in Replit Ask

1 Like

dang, that sucks man :frowning: