Replit erroring out since yesterday

I’m running a private Repl for around a month now, with no issues. But yesterday, it errored out with the following error:

Traceback (most recent call last):
  File "/home/runner/SimulationsHedge/venv/lib/python3.10/site-packages/requests/", line 971, in json
    return complexjson.loads(self.text, **kwargs)
  File "/nix/store/hd4cc9rh83j291r5539hkf6qd8lgiikb-python3-3.10.8/lib/python3.10/json/", line 346, in loads
    return _default_decoder.decode(s)
  File "/nix/store/hd4cc9rh83j291r5539hkf6qd8lgiikb-python3-3.10.8/lib/python3.10/json/", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/nix/store/hd4cc9rh83j291r5539hkf6qd8lgiikb-python3-3.10.8/lib/python3.10/json/", line 355, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/runner/SimulationsHedge/", line 1, in <module>
    import data.options_table as options
  File "/home/runner/SimulationsHedge/data/", line 2, in <module>
    import data.contracts_data as dt
  File "/home/runner/SimulationsHedge/data/", line 35, in <module>
    btc_data = btc_response.json()
  File "/home/runner/SimulationsHedge/venv/lib/python3.10/site-packages/requests/", line 975, in json
    raise RequestsJSONDecodeError(e.msg, e.doc, e.pos)
requests.exceptions.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

It seems the error is when fetching the bitcoin price from Coingecko API - but when I check the API manually it works, and Coingecko reported no issues.
When I run the same code in my PyCharm locally, it also works.

But on Replit it’s erroring out a second after I run the, and it still doesn’t work after many attempts in last 20 hours.

Would appreciate If I can get some help, what could be the problem here?

I believe things around crypto are not allowed here, so maybe they found out you are violating the TOS.
Not sure as I have no clue what your repl does.

1 Like

Hey @AntonK22! Welcome to the community!

When Replit updated one (or more) of your modules, it caught a bug that PyCharm did not, which caused the mentioned error.

You can report it to the developer of that module and create an issue or install an older version of the module.

1 Like

I think fetching bitcoin prices for statistics is okay, which I believe what @AntonK22 is doing. Just so long as you don’t use the Repl machine to mine/buy cryptocurrency (anything to do with changing crypto wallets in general)


Thank you Praquaron - and you are correct, I’m making simulations around price average movements of BTC and ETH - I don’t think it violates any terms (hopefully).

But back to my problem - I also believe the problem is in some module, but how can I know which one? I have no idea how to proceed now.
Sorry for my lack of knowledge there.

1 Like

Did you try to import modules one by one and see which one gives you the error?

1 Like

I did not. I have only 4 modules in my packages - I assumed it was the requests module (because it was mentioned in the error), so I uninstalled it and reinstalled it from the packages page, but same error occurs. I did reinstalled the same version as before. Is the proper way of doing that from the packages page?

The other modules on my packages page are web3, websockets, pytz and gspread. But when I do pip freeze, it shows a bunch of modules, that I haven’t installed myself, and are probably a part of those.

1 Like

Forget pip freeze as Replit has tons of stuff.
One way around is to fork your own repl. Enable auto import and see what happens …

1 Like

one question first - how can I delete cached files? maybe that will help?

What do you mean by cached files?

If you mean browser cache, you can do Ctrl+F5. Otherwise I’m not quite sure what you mean.

sorry, I misspoke about cached files, i meant like venv folder .
I did tried forking it now, and run it same error.

If possible (if there’s nothing in the repl that HAS to be kept private), could you make the fork public and provide a link to it? (If there is stuff that needs to be kept private, remove it as long as it doesn’t break the repl)

I was thinking the same. If you use api keys maybe replace them with some test free ones if possible.
It is nit necessarily a module error as it looks like the is a None propagating where it is not expected.

unfortunately I can’t do that, as its a paid data science job. And script is quite big.
It has to a module error or weird Replit error- I now downloaded all my py files to my computer, loaded into PyCharm, installed the modules, and it works.

On Replit still the same error.

and the most weird thing to me is that everything worked fine for weeks up until last night, and I haven’t changed the code or done anything.

If you downloaded the files already, try uploading them into a brand new repl, that isn’t a fork of the original. (That’s fixed a few of my projects before)

thanks for bearing with me here, let me try that.

Same error , 1 second after running

Going back and re-reading the error, it seems the repl is not receiving a response from the website. Either this is a temporary network glitch or something, or repls might not be allowed to make requests to that site anymore. I’m not entirely sure, but from re-reading, this is the only thing I could come up with.

1 Like