.replit `entrypoint` does not work with markdown files

I have a github project in which I have placed a Run On Replit button. My primary language is go. When someone clicks the Run On Replit button, I want it to default to a file called docs/replit.md where I have some useful instructions on how to proceed. To try to do this, I have added this line to the .replit file in my repository.

entrypoint = "docs/replit.md"

However, that does not work. When I click Run On Replit, the repl opens up to CODE_OF_CONDUCT.md, which is not very useful.

My github repo is here: GitHub - sushovande/qr-mixer-game: Host a website to conduct a fun party game!

Hi @sushovande welcome to the community and thanks for your question!

Have you tried putting ./docs/replit.md as the entry point instead?

Just tried it, didn’t work :frowning:

Can you share a link to the Repl please and I’ll take a look.

https://replit.com/@sushovande/qr-mixer-game

But the better test would be to click this following link and create a new replit of your own, so you can mimic the experience of someone who would click the “Run on Replit” button on the github page:

https://replit.com/new/github/sushovande/qr-mixer-game

interesting. It does work, but just not initially. If I reset the layout, refresh the page or fork the repl, it is replit.md which shows up. It probably hasn’t imported all the files yet when it chooses which file to show.

2 Likes

Yeah, I am seeing something similar now.

I guess the bug report then, will be: the system should wait for all files to be ready before attempting to act on the .replit entrypoint.

Thanks!

1 Like

Hi @StupidGenius and @sushovande that’s really interesting. I was looking at it from the point of view that the file shown was the first alphabetically as it could not find the entry point file. I hadn’t thought about the Repl attempting to display before all files were imported - good idea!

I agree that a bug report would be best for this one. Thanks for highlighting this!