Replit editor stuck disconnecting and reconnecting

Problem description:
One repl I have access to is stuck repeatedly reconnecting in the editor, site hosted by the repl is fine. Also, recent repl edits have been completely lost.

Expected behavior:
Editor does not boot loop, and edits persist

Actual behavior:
Editor is stuck in a boot loop, and recent changes have been lost.

Steps to reproduce:
Uncertain, you could check my repl.

Bug appears at this link:
https://replit.com/@Firecat650/git

Browser/OS/Device:
Chrome 113.0.5672.127 (Official Build) (64-bit) (cohort: Stable)/Windows 10 Version 22H2 (Build 19045.2965)/intel Laptop

Notes:

  1. It appears to be only this repl that is boot looping, other repls load fine.
2 Likes

Seems fine to me

it’s probably your platform

my bootleg solution:

close out tabs on replit, close out web browser. turn off wifi, turn wifi back on. go back into replit, try going in again.

(this might not work but just try just in case)

Just the editor. Website hosted is fine. Also, only this repl.

I tried a full system restart. No dice

Have you tried giving your device words of encouragement? Maybe it’s an emotional problem for your device.

Forked it. Yes, it’s happening to me too!

I made a quick little video on this:

Note that it keeps happening infinitely. I opened a file in the video but that is not the cause. It is still happening.

There should be a file in Custom > Config called app.ini, does it exist on your fork?

1 Like

Lemme check: yeah, there is a file there. Surprisingly, I can see text that I can edit.

When I do, nothing saves, the cloud icon blinks for a bit and then the repl disconnects, so it doesn’t save at all.

Interesting. That file is missing from my repl, though it’s definitely still acting like it’s there.

Also, fgit is either a bash script, or a complied program, which is probably why it doesn’t open.

Try coping all the files (the repl is: https://replit.com/@doxr/loop-around#custom/conf/app.ini) into a new repl?

Was it supposed to?

The weird thing is, the site still works, regardless of the repl crashing (see https://git--firecat650.repl.co)

1 Like

Several people are coming across the same thing? Do you think it could be on replits side and not our user error?

@doxr came across the error by forking my problematic repl, which means there’s definitely something going on here.

I’m thinking of asking the Replit Support Team.

1 Like

I doubt that they could do anything about that specific repl, but I will cheer them on as they do it.

1 Like

I’ll write up my steps to set up the repl, to see if it’s reproducable.

How did you resolve this issue. I’m experiencing the same thing.

Solved. I used ctrl-F5 and it resolved.