Replit Domain Linking is possibly degraded


Custom domain linking is failing after 48+ hours and with multiple (sub)domains. I have tried removing and re-adding the domains, and even attempted to use a different domain while waiting at least 48 hours.
You can run a DNS lookup yourself on the two subdomains of a domain that I’ve tried using: and



NOTE: Previously, the domain linking UI displayed a loading animation while saying that “something was getting in the way of their verification process”, and occasionally would say “DNS records could take up to 48 hours to propogate”.


Are you using Deployments or the old method? The old method (beta hosting) is now in maintenance mode and will not be updated (though bugs will be fixed IIRC). Deployments are supposed to make domain linking easier. Note that there is currently no free tier for deployments (so it will cost 20 cycles a day (20 cents USD).

1 Like

seriously… this is annoying.

Hey @python660!

It looks like you are including an A record in your DNS as well as a CNAME. If you remove either one, that should fix the issue!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.