REPLIT Deployment Failing with ReplDB

REPLIT DB fails in deployment whenever DB lines are used.

I am not very good at this deployment stuff, but recently I have converted all my old “Always-On” node.js REPLs into deployable repls.

Whenever a line of code that uses the db.get or db.set functions in the workspace or in the old always on state of the repl, it works fine. But once I deploy these repls, the DB codes always fail, and crash the code.

Repl link/Link to where the bug appears:

Screenshots, links, or other helpful context:

code snippet

Currently, Replit Database Proxies are not supported on deployments. This is an ongoing issue and I can only hope that the devs will add it in the foreseeable future

I have exactly the same issue and I don’t know any workaround that I could store and retrieve data from replit database using NodeJS with deployments. It simply don’t work.

The error “TypeError: Only absolute URLs are supported” does explain anything, and we cannot find any documentation regarding that.

Does any of you have any idea on how to fix or at least any way to have that working?

It always work fine with Always on repls, but now that we were basically enforced to move to deployments my applications stopped working.

Ok, I got it working in 2 different ways…
I noticed if I created a new repl, the issue didn’t happen, so I created a new one and copied all my files from my old repl to there… But I needed to get each entry of the old db and update on the new one manually (my db is small, so didn’t take much time). After that, I transferred the custom domain to this new repl

Once I made sure everything was working well on the new repl, I messed up with the old one to try to fix it as well. What worked for me was upgrading the node and npm on the old repl.
I went to the shell (from tools) and typed in there npm i -g node@20 and npm i -g npm@9.
Once both of them finished, I redeployed my application and it worked and the db.get / db.set is now working fine.