Replit crashing on attempting to download large file

Problem description:
Whenever I tried to download a 351 Mebibyte file to my computer from replit, it just loads indefinitely or crashes replit.

Expected behavior:
It opens a new window and downloads or a pop up saying “download file” comes up after some time, although the “download as zip”, which is way larger, starts downloading almost instantaneously.

Actual behavior:
Loads indefinitely or crashes replit upon clicking “download file”.
(EDIT: It works after crashing and some delay on safari with a 60 M file)
(EDIT: I’ve determined the delay to be definite, just absurdly long or crash)

Steps to reproduce:
Open repl then click the three dots → download file

Bug appears at this link:

https://replit.com/@dragonhunter1/DownToon (PRIVATE)

https://replit.com/@dragonhunter1/CyanPutridPriority (PUBLIC EXAMPLE)

Browser: Safari and Chrome
OS: IOS and Windows 10
Device (Android, iOS, NA leave blank): N/A
Desktop app version (Avatar menu->“Version”) or NA: N/A
Plan (Free, Replit Core): Core

1 Like

@dragonhunter1 Thanks for reporting. I’m using the latest version Chrome in my testing. I forked and downloaded the result.tar.gz file (about 60MB) from your public example. I didn’t see any issues.

If you click on my forked Repl to download the file, does it crash on your device as well?
https://replit.com/@SuzyAtReplit/CyanPutridPriority

Sorry, I realized that that one worked, but forgot to update the example. I will update it now!

Finished update, now https://replit.com/@dragonhunter1/CyanPutridPriority should have a 968 M file (Tested with crash confirmed after around 20s?)

Thanks @dragonhunter1. I can’t seem to make it crash but I can reproduce the wait. We are going into a code freeze for the holiday, but let me get this reported to the team.

If you can consistently make it crash, a video of that and a .har file would be a great addition to the bug I’m submitting. You can message to me directly with these items.

Otherwise, this Repl is a good example and we can work with that. Thanks for your help.

2 Likes