Replit Crash After a Couple Runs

Replit Quits Running in the Console and never Compiles code

For the code to run

I can create a simple app like

print("Hello world")
exit()

If I run this code 3 - 7 times replit will quit compiling the code and nothing prints in the console, and it continually loads. And i don’t hammer the button I wait and this will still happen.

This has been an issue for the past several days. I am not sure what’s going on or how to fix the issue… makes it hard when working with the replit db

Bug appears at this link: https://replit.com/@kupo2001/Day72100Days#main.py

n/a I could make a loom maybe

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36

Replit Profile: https://replit.com/@kupo2001

Using exit() or similar functions on 100 Days of Code repls (which use older configuration) causes a problem where when the repl is run later, it will get stuck on Working.
So, you should avoid using exit(), and instead let the program end by itself by reaching the end of the code.

This is a known bug (but I’m not sure which topic is the original).

2 Likes

I get the same problem, even if I don’t use no exit()
I run my repl several times and it works fine, add a couple of lines and then for no reason it keeps loading forever.
Tried to spam F5, reboot my computer etc… with no success.
I just wait one or two hours, and with no changes at all I’m able to run my repl a couple of times before I get the same error.

Type kill 1 in the Shell to restart the repl.
Possibly, another process-ending thing like SystemExit could be causing it.
Otherwise, could you share a link to your repl?

1 Like