Replit Console Taking Forever To Load

So idk if this is me or what but for the past 2 days if I try to run any code or make a new repl it takes like 5 minutes to load the console, and yes my wifi is strong. I thought it was just my clientside issue but it seems not? It’s been the same with my school account also.

Anyways, furthermore when I try to run a code [mostly discord bots], it takes long to install the necessary packages and doesn’t even start the code at all? Nothing is wrong with my code either, I’m fluent with my coding language [python] and everything works fine when I host it on my VPS.

Just wanted to know if this was some replit issue or something? It takes so long for the console to load, so long for the libs needed to be installed, and doesn’t even start the script if I try running it.

I’ve even tried a normal print statement and am getting the same results, nothing. All the while before the codes have been working perfectly fine and running stable, i’m not running something that big of a program to go over the CPU limit of replit either. I’ve tried making different repls and seeing if I’d get a different output. But it still takes forever.

May I also add on that downloading files as a .zip from replit also sometimes takes forever? The past few times I’ve been trying to download my files as a .zip instead to host on my vps but some don’t even download and cancel the installation process instead. It’s weird.

I don’t know if this is just my clientside issue or a replit bug, however i doubt its a client issue because i’m getting the same buggy process on my school account too.

1 Like

Can you provide a screenshot?

Yep, here ya go.

Btw this is the most recent screenshot, it’s been like this for a while. When I click run, nothing happens.
Same with every other repl whatever the language may be.

1 Like

This has been happening for me on C++ Repls but not others, I do not use Python so I do not know about that.

I notice two things,

  • Your repl has not loaded yet, so running wouldn’t do anything
  • Your RAM usage is completely consumed, likely because of some background task

You could probably fix these by using a simple python repl without all the fancy stuff like poetry and integrated console etc.

I make new python repls everytime, and it takes forever to load even though it’s completely new and empty.
I don’t know why the RAM is being consume so fast. I make new repls when I havent coded anything yet.

try closing all your other tabs?
maybe try renaming the repl (this will restart all processes of a repl).