doesn't automatically redirect to, even after logging in

Bug appears at this link:

Browser/OS/Device: Mozilla/5.0 (X11; CrOS x86_64 14541.0.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:

1 Like

That is not a bug though? That is how Replit has always worked I thought. :thinking: Can you please elaborate and explain what it used to do for you?

1 Like

Usually if i went to I would be redirected to [Home page with recent repls, etc], now it just sends me to the signup screen (Replit: the collaborative browser based IDE blah blah blah) and if I try to login it sends me back there.


Ah I see. That is indeed an issue.

Yeah, when I logged in earlier, it kept redirecting me to a section of the signup page, which was strange.


Hitting login just refreshes my page

1 Like

Hey @idorandomstuff!

Can you please try clearing your cache and cookies for then try logging in? If you do that, does that fix the issue?

1 Like

I can confirm that this happens to me too.

1 Like

Does clearing your cookies and cache fix it?

1 Like

I can still reproduce this, steps:

  1. Clear cache and cookies if you’re signed in, otherwise it won’t do anything
  2. Open
  3. Try to login with username and password
  4. Get redirected to the login again, with added parameters to the URL
  5. Try to login with email and password
  6. Get redirected to successfully

i think i just got banned i can’t autologin

You’re not publicly banned, if you’re banned at all.

i got like 20 warnings im definitely banned

Again, you’re not publicly banned, or you’d show up as “Banned User”, and you would be banned from Ask too.

Site mod here, just checked and you are not banned if your Replit Ask account you are on is the same as your main account.

1 Like

So on my laptop, Replit doesn’t keep me logged in. Now on my phone, on the Replit app, when I enter a repl, it loads for a bit and then opens Google, opens the login page for Replit. After logging in, it goes to my Replit homepage (still in Google). Then, I go back to the app to let the repl load, and it does not load, so I exit and go back in, the cycle repeats and I cannot actually access the repl on the mobile app.
This is inconvenient and inefficient. Can this be solved please?

I reported this exact thing. It’s really crucial because it’s affecting my flow. Every time I try going to because it’s auto-saved in my browser auto-suggestion and it leads to the landing page. Why can’t it detect that I’m already logged in? It used to just fine, the past 3 years.

To be clear, you are actually still logged in. If you open it should load your homepage properly. It’s just not redirecting automatically anymore for some reason.


This gives rise to an annoying problem:


To be super clear is this happening both in the browser and mobile? I’ve just tried to recreate the issue in Safari and Chrome (MacOS) and found the redirect to be working. I’d like to recreate the issue and get this over to the team. Thanks!

1 Like