Replit can't update changes

my replit proyects can’t update changes, what’s going on?

Hey @reptitalz welcome to the forums!

Can you please elaborate on your issue and share a link to your repl


Bug description:
For some reason no matter what change I make to my code and then re-run and re-deploy those changes are not propigating (even though it says success)I have tested many times with simple console.logs. I have also tried in multiple browsers and removing my cache.

Bug appears at this link:

Browser/OS/Device: Arc, Mac

Replit Profile:

(I am not a mod or staff, so yeah)
Hello, please consider looking around the replit bug reports section before posting this, as there is already a post about this topic. Thanks!

I just posted a similar bug and then noticed your post. I seem to be having a similar problem. I changed a basic print statement and it seems to be saved properly but when I run the repl it always displays the old data in the print statement. Hope they can fix soon.

Confirming there’s a significant problem apparently with the file system. Edits made in the GUI editor persist in that editor, surviving reloads, logouts and so on, but these edits are not found in the files that are compiled (or tracked by git). The differing state can be seen by cat-ing the file in the shell.

I’ve seen other vaguely written posts that appear to confirm (it’s hard to write about clearly because the phenomenon is strange).

Steps to reproduce:

  1. in some project (mine is C++ edu team, using git) open and edit a source file
  2. no problems for sometimes hundreds of edits, or tens of minutes
  3. then, on an apparently arbitrary edit, the edit is not “seen” by compiler or git. if there’s a syntax error, you’re stuck with the syntax error in that file indefinitely.
  4. go to the shell and cat the file. the file presented there will not match the one in the GUI
  5. no amount of fiddling in the GUI editor will cause this file to change in the file system (including delete and recreate)

I’ve found, struggling with this since yesterday am, that after several hours pass, the file becomes re-synched, but the process repeats some few hundred edits later.

1 Like

I’m having this issue as well. I’ll fix an error, but then when I run it again I get the same error, citing the old issue. Even if I add returns and change the line of the problem code, the error message cites the old line number as causing the issue.

1 Like

Hey @AlexandrosMatho and everyone else – this looks an awful lot like an issue with content not updating correctly we are actively looking at.

I don’t have a lot to share right now but keep an eye on


@reptitalz echoing @not-ethan – if files are not updating it very likely is a problem we’re looking at here.

Problem description:
I have a repl that loops and has a print statement:

print("Current UTC hour (target = 15-17): ", dt.datetime.utcnow().strftime("%H"))

It used to be set to: (target = 15-16)

I just changed the code recently. All it is doing is printing in the console this information. The problem is that after I updated the print statement in the file and waited for my repl to show the checkmark that it has updated, when I rerun the repl the print statement is old code! The print statement still says (target = 15-16). I don’t understand why is using the old information! I updated, I saved, why doesn’t it use the updated code?

I am using a Teams repl.

Expected behavior:

It should say: (target = 15-17)

Actual behavior:

"Current UTC hour (target = 15-16): "

Steps to reproduce:

I let it save, run and even rerun and it still is using the old file.

Device (Android, iOS, n/a leave blank): Mac, Brave Browser
Plan (Free, Hacker, Pro Plan): Teams Pro

Hello @avataraustin!

Could you give us a Repl link so we can help you?

1 Like

it’s a private repl. Its ok though, I have since learned from other posts that there indeed is a file system problem where edits made through the GUI are not actually updated to the live file. I hope Replit is able to fix in a timely fashion.

1 Like

I wanted to see the Repl to see if it’s a bug in the code instead of a bug with Replit.

1 Like

Hey y’all! This looks like an issue with content not updating correctly we are actively looking at. I don’t have a lot to share right now but keep an eye on

This is a question about odd behavior I have noticed in Replit in multiple repl’s. Sometimes I will make changes to code, but the changes seem to be ignored. By this I mean they will not change the behavior or appearance of the program I am writing, will not trigger any changes in need of committing in git, will not even show up in code search of my repl (in fact, code search will still show old code that has been replaced, and clicking on the supposed location of the old code will take me to the location and show the new code in the editor!)

This has happened multiple times both in a project I am working on in React Typescript, and a project in node.js. The only “fix” seems to be closing Replit for a few hours and then trying again. Has anyone else noticed this behavior? Any suggestions about how to prevent it from happening? Thanks!


Yes, replit seems to be non-responsive for many users this has started today, but for me this has been an issue for 2 days & no matter what I try I can’t open my repls.

Thanks for holding on – we deployed an update that should fix this for everyone. Thanks for holding on and please reply back if you’re still seeing similar behavior.



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.