Replit-Bot (my package) does not appear on replit

Problem description:
Attempting to download my package (which I can download locally) doesn’t work on replit

Expected behavior:
pip install replit-bot should install it

Actual behavior:
when running pip install replit-bot

Steps to reproduce:
make a python repl (or any repl that has pip) and run in shell: pip install replit-bot

Bug appears at this link:
here

Browser/OS/Device:
NaN

Possible reason: replit has manually blocked my package, but I don’t see this being the case
EDIT: it is clearly here, that is to say, it is a pypi package
EDIT 2: after trying to install via poetry, it seems replit is experiencing some python installation hitches?

if your package supports python 3.10, update the python requirement on it to ^3.8

2 Likes

I don’t believe that’s the problem but thank you

It is, at least for the last error.

The current project's Python requirement (>=3.10.0, <3.11) is not compatible with som e of the required packages Python requirement: replit-bot requires Python >=3.8.0, <3.9, so it will not be satisfied for Python >=3.10.0, <3.11

So you have python 3.10 and your package needs python 3.8 (>=3.8 <3.9)

Update

Your first problem can also be simply solved. When you install a python package on replit it goes through a replit proxy, not directly pypi. because of this some new packages have not been updated on the proxy yet. The solution is to wait.

2 Likes

you are correct :smiley: thank you

1 Like

Hey there what ended up happening is that replit updated to 3.10 repls and my packager was made before that change on replit so the code had a python requirement of the very, very specific 3.8 only which is why it did not run, thanks for your help

EDIT EDIT: You now need everything to be 3.11 XD

I’m sure you could’ve got to the answer yourself if you had read the error

Thank you :smiley: I didn’t realize since I was trying to install it via pip which does not have the error