Replit app editor is completely unusable

Problem description:
The replit app is being a nuisance today, and the website isn’t any better. I am not able to get any work done while on mobile.

Expected behavior:
No red and yellow dots overflowing on my screen, and no random movements that hide the cursor and can potentially cause me to mess up my code.

Actual behavior:
Red and yellow dots overflowing onto the screen, and random movements rendering the editor unusable.

Steps to reproduce:
Open editor and start typing (or idling, both options work).

Bug appears at this link:
I’m not sure if this is just me, or if there is just some sort of OS glitch. I’ve included a screenshot below.

Latest version of android, running on the mobile app.


I cannot reproduce this issue on my Android phone (Pixel 3).

Hi @python660 thanks for your post. You will have to include a link to a Repl which displays this issue for you. Then others in the community can also test the same Repl and see if it can be replicated.


All of my repls are having this issue. Whenever I use the app, half of my code also magically disappears.

Hi @python660 I’m not able to replicate your issue and you haven’t provided a link to your user profile so the community can take a look. I think (from the screenshot and information you’ve provided so far) that the issue will be device or firewall related.

1 Like

Hi @IanAtReplit , I’m actually experiencing the same issue … I tried deleting the dots and starting over but these dots spontaneously appear again as I’m working on the app. I don’t think there’s any rule to these dots, other than the fact that I was working on some code inside a for loop block.
I’m using the Android app on Galaxy S7 tablet, with logitech k380 keyboard. Not sure if the issue reproduces without external keyboard. thanks.
Where it happened:


Thanks @minahkeem that’s really useful. I’ve passed on the details to Replit support again so hopefully there is something in common between the two reported issues.


Hi again @minahkeem we’ve spotted something in your Repl:


I noticed you said you tried deleting the dots but they spontaneously appear when working in the app. Did you type in the code to the right of the dots or was it copied and pasted?

1 Like

@IanAtReplit I typed the code to the right of the dots. I was typing the “total_tip …” line when the dots started appearing in front of it, and then the same dots started appearing in front of the other line in the for loop (#print…) and in front of the for loop as well. I had the same situation prior to this one where over 100 dots appeared in front of another code block (same project), and I manually deleted everything… maybe you can see this earlier case in history.


Thanks @minahkeem it’s definitely a bug. Thank you for your help in identifying this!