Replit AI/Ghostwriter Input + Vim Keybindings issue

Problem description:
I turned Vim keybindings on, and the Ghostwriter input has it enabled as well.

Screenshot 2023-11-13 at 11.31.55 AM

Expected behavior:
Regardless of keybind settings, Ghostwriter’s should be set to default.

Actual behavior:
Ghostwriter should not use vim keybindings, regardless of editor settings.

Steps to reproduce:

  1. Set editor keybindings to vim
  2. Open Replit AI / Ghostwriter and put your cursor in the input
  3. You’ll notice you can’t type anything unless you enter insert mode

Bug appears at this link:
Confirmed to appear in any Repl

Browser: Chrome (Repro’d in both Chrome/Desktop app)
Device (Android, iOS, NA leave blank): Macbook Pro 14" Sonoma
Desktop app version (Avatar menu->“Version”) or NA: 1.0.5
Plan (Free, Hacker, Pro Plan): Pro Plan