Repl wont wake up

My repl has been unable to wake up for 3 days and i don’t know why its taking so long
Repl link

Have you tried to go into the Repl code editor and hit run? If so, then this is really weird. I added the Repl to the Cactus Pinger to try to keep it alive.

Thats one of the first things i tryed when it wouldn’t work 3 days ago

I thought it likely but it doesn’t hurt to check. I’ll let you know if I come up with anything more.

After forking the Repl I found the problem: line 72. You declare a global variable username. In Python, you must declare a variable global before it ever gets used, not after. Some people recommend never using global variables at all in Python because of how tricky they can be (that doesn’t stop me though). After commenting that line, I got my fork to work (even though it wouldn’t before).

1 Like

Any error like this can stop your repl from working or displaying anything. Always check the console for errors first

1 Like

No, It won’t work.
According to @soren,


Repls can still receive pings, But they will not “wake up” the Repl.

do you want to try and fork the repl?

this will create a new repl with the contents on a new machine

No changes have been made yet.

Have you tried deleting line 72? My fork wouldn’t run until I did that. The problem seems to be that your Python has an error (variable username made global after declaration instead of before), and the Repl wakes up once you delete that part of the code (which doesn’t help the site features, but at least wakes up the Repl). Please at least tell me if doing this fixes the waking up problem.
Here it is:

1 Like

Looks like the problem’s fixed now :smiley: I runned the repl from the cover page & it’s alive!

1 Like