Repl wont run: Disk quota exceeded

Bug description:
nix error: building nix env: exit status 1
error: creating directory ‘/tmp/nix-shell-8165-0’: Disk quota exceeded

Steps to reproduce:

  1. Install chromium
  2. Run it for a few days.

Bug appears at this link:

Browser/OS/Device: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36

Replit Profile:

I believe this means you exceeded the maximum amount of disk space that replit allows.


Hi @Roosteridk yes @bigminiboss is correct. Are you using cycles at all to give your Repl more space? This might resolve the issue.

1 Like

Hi Ian, thanks for your reply. Firstly, I don’t think the issue was with the storage limits as my usage was way below the 4GB limit. Something weird happened when I tried to run the Repl again today. The disk quota exceeded error disappeared and now it works fine. I deleted all the temporary files yesterday and maybe the changes were reflected only a while after. Weird.


Thanks for replying @Roosteridk and I’m glad the issue is resolved for now. If it happens again please let us know and we can take a look!

1 Like

Hi @IanAtCSTeach, the problem seems to be reoccurring. At first, I thought it might be a puppeteer related bug but I don’t think that’s the case. I hope this screenshot will help clarify the issue:

As you can see, /tmp is barely used yet it says Disk quota exceeded when I try to create a new directory. And here is my Repl resource usage:
Pretty much no storage used.


Try after rebooting your repl: kill 1 in shell.
The repl link you sent 404s. If it’s private, link a minimal repl which reproduces the issue

1 Like

By the error you’d think that while booting nix the project hit its limit.

1 Like

Thank you for the information! I have asked the team if there is something we can do about this. I will follow up as soon as I get a reply.

1 Like

Can you run df -h /tmp to check the size of the /tmp directory? We have a 1GB limit for all files in and outside of the Repl’s main directory (/tmp is considered an “outside” directory).

1 Like

Update: doing kill 1 as @UMARismyname suggested seems to have fixed the problem for now!

And here is the /tmp usage:

~/5$ df -h /tmp
Filesystem      Size  Used Avail Use% Mounted on
/dev/nbd0        32G   21M   32G   1% /tmp
1 Like

why is there a limited amount of quota

1 Like