Repl will not load (displays moving Replit Logo)

Problem description:
Students tried opening an existing Python project repl in a course created in Replit Education. Students also tried creating a new Python repl from their home screen. The repl appears to begin loading, but then the screen is replaced with a loading screen of the moving Replit Logo.

Expected behavior:
The repl should load with the students having the ability to edit and run the code.

Actual behavior:
The repl appears to load but then is replaced with the Replit Logo like it is caught in a loop.

Steps to reproduce:
Using a student account, try opening a new repl (I used Python, but HTML also did not work). Or within Replit for Education, open an existing project.

I am not having this problem as the instructor.
This problem is not consistent among my students. It is occurring on some personal devices, but not all. It is occurring on some school devices, but not all. It is occurring connected to the school Wi-Fi as well as connected to personal hotspots.

Bug appears at this link:
https://replit.com/@acc-csp-2023/712-Project-Strings-and-811-Project-Lists-BryanS5

I can open his project as an instructor, but he cannot open his own project.

Browser: Chrome
OS: Windows 10, Apple IOS, Chrome IOS
Device (Android, iOS, NA leave blank): Windows Laptop, Chromebook, iPad
Desktop app version (Avatar menu->“Version”) or NA: NA
Plan (Free, Hacker, Pro Plan): Education

3 Likes

This is a short video of the problem from my student on an iPad.

1 Like

I am also having this same issue.

1 Like

Hey all!

We recently resolved an incident internally that might’ve caused this issue. Can you please check to see if you’re still seeing the infinite loading issue?

2 Likes

We are having this problem as well. Some students can’t load any repls, others seem to be working fine.

1 Like

We are having the same issues. About half my students are not able to view their code and they’ve been having this problem since last night.

2 Likes

Same issue here. When I make an anonymous user account I can reproduce the error. Even after making a new class within the organization and making a new anonymous user account, same issue. Tested in yet another new class without the anonymous user feature, for students 13 or older, and it seemed to work normally. Possibly an issue with either anonymous accounts or ed accounts generally.

2 Likes

I was finally able to have some students try it and they are still encountering the same problem.

1 Like

I am having the same issue. It seems to be an issue with anonymous or student education accounts.

1 Like

Three-quarters of my students could not access any of their projects during my class today (1:00-1:30 central time). Same symptom of the Replit logo animating endlessly. We tried updating Chrome, restarting laptops, and flushing the cache and cookies, to no avail. The few students who got it working said that they just hit refresh a bunch of times and eventually it worked.

1 Like

Same problem with my class. 3/4 of them are experiencing the endless replit logo and not able to access assignments I have posted to our team. My student test account is having the same problem. I wonder if it has something to do with the type of account. All the accounts we are having trouble with were created to be coppa compliant and students did not use an email address, but simply created a username.

A few days ago, I tried logging in with my test account and replit displayed this message.

I tried accessing the team from another student account using email as a sign in and had no trouble accessing the assignment. I wonder if the issue is with this type of account and the way replit is logging them in?

1 Like

We are having the same issue with some (seemingly random?) of our students’ accounts. If students create a new replit account using their personal account, I can add them to the class, and they can continue to work on future assignments, but this is not a viable solution as they do not have access to all past assignments.

1 Like

The issue has been acknowledged on the status page. Hopefully the issue will be resolved soon.
https://status.replit.com/

1 Like

I just tested with the three students that were having the issue in my class, and for all three of them the issue is now resolved, so it does appear that the issue with those that joined the Edu Team using a private join link was the culprit.

I have an update for everyone on this issue that it should now be resolved. Please verify the fix with your students at your earliest convenience.

I was able to do a refresh and see the fix applied without additional steps. However, if the fix is not readily apparent, I recommend logging out of Replit and clearing the browser cache. You may wish to have the student test that they can access the project both from the Teams section and from their recent Repls, as applicable.

4 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.