Repl violating TOS Bypass

Problem description:
When a repl of mine became “temporarily unavailable” for violating TOS, I could fork it and go back to viewing, editing, and running it. I’m not sure if what i was making broke the TOS, but its possible.

Expected behavior:
I shouldn’t be able to edit/view the code.

Actual behavior:
I can fork to get around this and continue working on the project.

Steps to reproduce:
Create a repl.
Break TOS and get locked out of the repl (message saying " It may be temporarily unavailable or it may have violated our Terms of Service")
Fork said Repl

Bug appears at this link:
here is my blocked repl
here is the fork I made of it

Firefox, Windows 10, Desktop PC

I didn’t have my repl blocked for breaking tos, as it is back now, but I still think this could work if a repl were to be blocked for tos

It seems to get locked every time i connect to the proxy at “” in an https request.

This is sometimes suggested here as a method to bypass that error. That error is actually pretty generic and not always related to the ToS.

Here is your problem. Replit forbids proxies as a workaround for restrictions (such as making a proxy to unblock games at school) as this tends to get Replit banned in schools. So, Replit tries to automatically block proxy Repls. If your Repl proxy is not meant to bypass any restrictions, you can make an appeal at Otherwise, I’m afraid it is against ToS.


Thanks so much! Have a nice one!

1 Like

You’re welcome! If I solved your problem, please mark the post that solved your problem as the solution so others will know.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.