Repl is broken! Console not working at all

I was trying to install the AWS CLI using the Shell.

I used the command aws configure and the repl used NIX to suggest that I use aws.out, awscli.out, or awscli2.out to execute it.

No matter which one I tried, it wouldn’t work — it threw a full page of errors and suggested trying the others:

nix error: building nix env: exit status 1
Output has been trimmed to the last 20 lines

[redacted the long list]

error: aws has been removed: abandoned by upstream. For the AWS CLI maintained by Amazon, see 'awscli' or 'awscli2'
(use '--show-trace' to show detailed location information)

But as a side effect, my console broke! It showed me the following error:

unable to start repl process exec: "prybar-python310": executable file not found in $PATH

Expected vs Current Behavior:
The console doesn’t work at all. It’s just blank. When I “Run” my overall web application, nothing happens anymore.

Steps to reproduce:

  1. In the shell, use the command aws configure
  2. Follow the steps and see them fail after you install them using NIX.
  3. Try to remove mentions of “aws” in the nix file, and still the console doesn’t work…

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/110.0

Replit Profile:

I’m having the same issue. I was building a website using Flask and it kept saying that something was already using the port I was trying to use, it was the default on the Flask template(port 80), so I tried to run a command to see what process was using the port, so I could close it. Long story short it ended up causing that to happen anytime I try to run anything python on here.

I have figured out, if you run the command “export PATH=”$PATH:/usr/local/bin/python”” in the shell, then run python {yourfile}.py, it will work, but you have to do that every time you want to run it. It removes the python command after the python file is stopped.

An alternative would be the “Secrets” tab on your Repl toolbox. Set a variable named “PATH” to /usr/local/bin/python:$PATH. Then you don’t need to do it every time you want to run it.

I’m thinking it has something to do with the replit.nix file, I may try to copy that file from an existing, working replit, and see if that fixes it

That seems to work. Copy your replit.nix file from another project and run the python command. For me, it errored the firs time and worked subsequent times.

Interestingly, after I gave up on it, and came back the next day, the shell was automatically working again. And I have no idea how.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.