Repl failing to deploy on the last step: promote

Description of the problem (please keep it simple and short):

  • Trying to deploy to production, keeps failing on the very last step
  • Logs below:
info: Deployment: aa55b76b-feb3-42b3-8979-627f1d3b3664 - 2023-07-26T13:48:34.306Z
info: Build: e098a5e7-7956-4e3f-bdf7-68b5c1ee0dbd - 2023-07-26T13:48:34.308Z
info: Connecting to builder - 2023-07-26T13:48:34.309Z
info: Builder connected - 2023-07-26T13:48:38.972Z
info: Installing packages - 2023-07-26T13:48:39.093Z
info: Skipping Build as no Build command set - 2023-07-26T13:48:42.029Z
info: Language - 2023-07-26T13:48:42Z
info: Pushing pid1 binary layer... - 2023-07-26T13:48:42Z
info: Created pid1 binary layer - 2023-07-26T13:48:43Z
info: Skipping Python layer creation - 2023-07-26T13:48:51Z
info: Pushing hosting layer... - 2023-07-26T13:48:51Z
info: Pushing Repl layer... - 2023-07-26T13:48:51Z
info: Retrieved cached nix layer - 2023-07-26T13:48:51Z
info: Created hosting layer - 2023-07-26T13:48:51Z
info: Created Repl layer - 2023-07-26T13:50:03Z
info: Pushing Repl (cache) layer... - 2023-07-26T13:50:03Z
info: Created Repl (cache) layer - 2023-07-26T13:50:19Z
info: Pushed image manifest - 2023-07-26T13:50:19Z
info: Pushed soci index manifest - 2023-07-26T13:50:20Z
info: Creating virtual machine - 2023-07-26T13:50:26.360Z
info: Virtual machine created - 2023-07-26T13:50:35.470Z
info: Waiting for deployment to be ready - 2023-07-26T13:50:35.574Z
  • Code works fine in the development environment
  • I’ve also added my environment variables to the deployment
  • I have a custom domain set up as a CNAME subdomain on my main domain

What areas or features are involved?

  • Deployments
  • Custom Domains

Additional question

  • I have a google service account JSON added as a secret (works fine in dev environment), but should I be pasting that entire JSON in as an environment variable for deployment? Something tells me I shouldn’t be because it doesn’t look like environment variables are hidden/encrypted.

Help would be appreciated here, thanks!

Here’s the specific error:

Your app failed to promote

It looks like something went wrong on the production server. It might have something to do with your apps logs. Please fix any issue and try deploying again or see troubleshooting tips.

App basics:

  • Flask app that catches/sends webhooks to and from Slack, processes a form, does stuff on a google drive with a google service account, sends that info back to Slack - all tested and working fine in Dev environment

Thanks for your message @KeaneAngle and sorry for any inconvenience. I’ve added @soren to this topic so they can hopefully investigate further.

Similar issue, with failing at the last step promote. This is for a background worker deployment. Python code.

Facing similar issue while deploying an Angular App. Logs showing no deployment error in all App logs.

Please help.

Same issue here. Did anyone ever find a solution?

I’m just ignoring it for now and hoping for a fix before I need to move my code into a scalable production environment

Hi, sorry for the late reply. @KeaneAngle @digitomanai @mustafapeshawar @Lukewhite9 if you are still having issues deploying your Repl, please feel free to sign up for a debugging session on Calendly: Calendly - Replit Deployments Team

Same issue.
No errors, only fails to promote.

image

Hi, we can’t debug this without more information. Please provide a link to the Repl and a screenshot of your application logs. Have you read through the troubleshooting guide?

Look here.
I have made my own topic, because mine was a somewhat different bug that was not logging or error-ing at all.

1 Like

Has someone began looking at this issue?

I recently am having waaaay more concerning Deployments.
Wondering when this downtime will end?

I’ll reply on the other topic.

Did anyone got the solution I am also facing the same error

I’m going to mark this thread solved since it’s old. Failing to promote can be caused by many reasons. Start with our troubleshooting guide first and if unresolved, it’s best to start a new topic with a link to Repl, deployment logs, and what you have tried so far for the community to better assist.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.