Repl Disconnecting Problem Though Internet Connection Strong

Problem description: Repl always disconnecting and reconnecting every 5-10 seconds though I have a very good internet connection.

Expected behavior: To stay connected.

Actual behavior: Always disconnected.

Steps to reproduce: Open repl.

Bug appears at this link: All of my repls: https://replit.com/@nuechterleinip

Browser: Replit
OS:
Device: Chromebook
Desktop app version: NA
Plan: Free

This could be related to Projects not loading and/or filesystem is not available (I/O Errors). You can check status.replit.com for updates.

No, it is the repl just not being able to consistently be connected. Everything loads fine, it’s just I can’t try it because it isn’t connected.

they fixed a problem with the asia region, and it still doesn’t work. I have also tried reloading, closing the tab and reentering, and even a hasteful kill 1 in the shell. none of it works.

What happens: I load the repl, I wait for everything to load, and almost at the same instant the notification “connected” pops up, then “reconnecting”.

could somebody help me out?

Pretty sure it’s related to the existing issue. Status.replit.com says the issue is fixed. Can you confirm that you’re still experiencing issues?

1 Like

this was recorded yesterday, but it’s basically what happens.


this was today, just now and the same thing happened.

yes, when I came into status.replit.com, it said “All systems are go!”

I tried kill 1, which was suggested somewhere with someone having almost the same problem.


just for you to see what happens.

Pay Attention to this!

Replit shows the no internet symbol next to the files. This seems to be an issue with replit in general lately. I would recomend trying to create a new project and see if it works or not. It’s possible a glitch still isn’t fixed, since the same thing happens to me several times a day.

My best guess so far is replit is getting too much activity for it to handle efficiently (server proccessing issue). I rarely get a “too many messages” warning, which fits with my theory.

For now if you have Python Idle, download your project and work on it from Idle. You can update the replit later if you have to (to export click the 3 dots, download as zip).

A temporary fix for me is to reload the tab. You can also try clearing replit’s cache to force it to recall all the data upon loading the replit (warning: will lag first time run)

If you can give more info, I have a better chance of finding a definite solution.

*Note that this is just my best guess, since I have no experience with replit’s servers, this is just based on some DYI code projects of mine.

1 Like

the thing is, I’ve tried reloading, closing and reopening the tab, almost everything.
and there really isn’t much more information to give. all of it is in the videos.

You should check your cookies though just to make sure. Video when it gets reconnecting state, then click the lock symbol in the upper bar, to the left of the link. Video clicking on the connection menu, the cookies menu, as well as the sub menus in the cookies menu. If there’s not an issue there, then it most likely is replit’s servers themselves. If so I’d recommend reaching directly out to replit by email, or through a staff member. If there are any issues there, then I’ll have to experiment on my own laptop to see what’s doable (+ research).

I think you can slow down the video. If not, then oh well.

I forgot to ask before, does replit only sometimes not work, or does it always do that. If it sometimes works, I’d download CloudFare Warp, and experiment with different settings to see if it’s based on the address (which is how replit decides which server you access from, or at least most likely how replit decides that)

I’m not seeing any apparent problems with the cookies. Have you checked the site permissions.

edge://settings/content/siteDetails?site=https%3A%2F%2replit.com is the Microsoft Edge URL for replit site permissions, you could try replacing the edge with chrome, so chrome://settings/content/siteDetails?site=https%3A%2F%2Freplit.com (I’m not entirely sure).

Javascript, Images, and Background Sync should all be Allowed. If any aren’t, that’s the most likely culprit.

Failing this, we could dive deeper into the specific cookie data (though to what extent I’m not sure) and check for any differences between mine and yours.

If we fail at everything above, then it’s either a device specific issue (though that wouldn’t make much sense unless replit screwed up something internally, or a glitch), or replit’s servers just have too much data being sent/received. (In which case we’d have to talk to the devs to figure out a temp bypass to the error, such as some way to choose the server connected through if it’s a multi server system.)

  • Again, I don’t have core knowledge of replit, these are my best guesses

Edit:
Currently learning a bit more about server setup if I can. From what I’m hearing, it’s seeming like a server side issue. I would still try the above ideas, just in case, I’ll reach out when you respond or when I learn more.

1 Like

@Firepup650, as a junior moderator, do you have any knowledge of replit’s base system? The information I’m offering is basically my best guesses, so anything you can add would be helpful!

I’m not sure on this one, since this seems to randomly occur for users randomly, and then (usually) goes away on it’s own, so… :person_shrugging:

My best suggestion here would be to watch the network logs in devtools to see if a specific network request is failing, and then if it is, trace why it’s failing.

(Side note: While I don’t mind, please avoid pinging users who haven’t participated in threads in them)

2 Likes

Sorry, I noticed you editing, but I didn’t really think it through before I messaged you. That’s my bad.

In note to the question, my theory of a overload on replit servers seems more and more likely. I can’t really replicate the issue though (especially if it’s based on IP, changing the server you’re connected to). Are there any servers that get a much higher amount of usage? Can you force connect to an alternate server? I can’t think of a way besides a VPN through outside tools. But maybe replit has it built in as a hidden devtool?

The most important question in any case is the way replit works. Does it process data from a main server, then send distribute it to sub-servers, or does replit just have a bunch of servers for different locations, that do the same thing? If it is a collection of servers, than what system checks the core code between them? When replit goes down, after a certain amount of time, other replit’s go down (suggesting a connection).

Hmmmm… Do you have access to the info or have the contact of someone who does?

I get why not to ping users who haven’t participated in the thread already, but does that apply to the devs? I could also email one of them directly if I had to, I’ve noticed several of their emails at this point (though it does seem likely that there’s a contact page I was too lazy to look at)

1 Like

Generally, if a topic needs staff attention, we mods will privately invite them to the topic

1 Like

so does anybody have anything that could help or need more information?

I mean, I just have the questions I mentioned. If I can get some basic information on how replit servers work (obviously not code or anything of the sort, just whether it all goes through one big server for example, or if some servers have more traffic than others consistently, and what is base for determining which server run through if multiple). Is there a efficient way to ask for these things without bothering them too much.

Working on it. Did you check the site permissions? Also, did you test a VPN to see if that worked? Is it constantly showing that error on the project, or does it only happen sometimes?

it’s constant. I think it started a week ago or something.

and the site permissions are in my last video. if you pause it right, you can see them. go into fullscreen if it’s too blurred.

Where are the dev tools.?.

So the issue doesn’t seem to be with your device (unless it’s some root issue in which case I can’t help), and I can run the replit fine. I forked it and I’ll mess around with it some to see if I can replicate the issue.

Ok, It boots fine in the editor, and run fine. Is the issue happening for multiple replits?

1 Like

F12 should do the trick.