Reactflow nextjs not loading

I tried to replicate the nextjs repl and adding reactflow, but it doesn’t load.
Can someone check


1 Like


I don’t understand. What isn’t loading? Replit (or perhaps one of the files) or the website? The website loads this, but I don’t know if it’s related.

Please provide more details so I (or perhaps someone else) can understand the situation here.


The repl loads, it’s the webpage that doesn’t show anything and it’s supposed to.

Its been really difficult to get anything to run on replit, even basic stuff, really frustrating and defeats the purpose of the easy IDE…not supporting docker to an easy way to just run anything is a major obstacle to adoption and I may have to leave it.

Also would prefer to pay to have support than paying and not getting official support.

Like webservers not loading? Usually, it’s the person who coded the thing that coded it wrong. Dunno if you coded your project wrong because all of my webservers work fine. What does it say in console when you press run?

In order to do that, to my understanding, you need root access, and since Replit runs in a VM IIRC, getting root access is dangerous lol

Replit doesn’t suit everyone, I guess.

What kind of happens is that people ask simple questions that someone who knows Replit by experience can answer. No need to get staff involved if a regular volunteer will do it for them. Any big problem can be emailed to which is the support email.

I myself don’t fully agree with how Replit sends every problem to Ask but some problems are better handled by community members.


I thought it was

1 Like

I couldn’t find a support email anywhere, thanks for that

Well I just copied the official nextjs repl and added the official react flow example app.

Also tried to have auto create the repl from my github repo.

The exact same code runs fine locally, no shell errors on replit, just doesn’t load the page and shows that replit error you showed.

its a standard nextjs app nothing fancy