React app stopped working - Vite internal server error

Hey. I worked on my react app all day yesterday no problem. I used it last night just before bed. Didn’t edit anything, just used the app and it worked. I accessed the repl using the custom domain. So I know I didn’t change any code by mistake. Was simply viewing the page. When I woke up this morning, it no longer loads and I get this error:

[plugin:vite:react-babel] [BABEL] /home/runner/TenIdeasProto/src/index.jsx: Cannot read properties of undefined (reading ‘Function’)

The web view on replit and the custom link are both giving the same error. Has anyone seen this before? I assume it’s a backend problem on replit, but the site says all systems operational. Again, I didn’t make any changes between last night and this morning. It worked last night, and then stopped working this morning. The console on the repl says:

[vite] Internal server error: [BABEL] /home/runner/TenIdeasProto/src/index.jsx: Cannot read properties of undefined (reading ‘Function’)

That’s why I’m guessing it’s something on the replit backend? I’m not sure what Babel or Vite are exactly and have never done anything with them.

This is the rest of the error:

at /home/runner/TenIdeasProto/node_modules/@babel/generator/lib/node/whitespace.js:169:35
at Array.forEach ()
at Object. (/home/runner/TenIdeasProto/node_modules/@babel/generator/lib/node/whitespace.js:168:134)
at Module._compile (node:internal/modules/cjs/loader:1101:14)
at Object.Module._extensions…js (node:internal/modules/cjs/loader:1153:10)
at Module.load (node:internal/modules/cjs/loader:981:32)
at Function.Module._load (node:internal/modules/cjs/loader:822:12)
at Module.require (node:internal/modules/cjs/loader:1005:19)
at require (node:internal/modules/cjs/helpers:102:18)
at Object. (/home/runner/TenIdeasProto/node_modules/@babel/generator/lib/node/index.js:11:18

Same here - also no longer works after last night. Didn’t change anything

1 Like

Still not working. Getting the same error.

I tried using the package manager to uninstall and reinstall vite and babel. No success.

Interestingly, my other programs and even other react apps still work. It’s only the one that stopped working Saturday morning. I had one other repl once that suddenly stopped working and gave an internal error I couldn’t decipher. That one came back on its own about a day later, so I assumed it was a bug and fix on replit’s end. Hoping this is similar and maybe will be fixed after the weekend?


Not sure what the answer was, but I ended up creating a new React repl and copying each file I had written to the new repl. That worked.

So I’m back in business. But no idea why the first stopped working


If you face that error again, a link to your repl will be helpful to see the problem(because to me it looks like a problem in code which occured after a visitor tried to access something)


Hey there! Welcome to the community!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.