Python Turtles NOT Showing Output

Problem description:
Python Turtles NOT Showing Output

Expected behavior:
Should Show

Actual behavior:
NOT Showing

Steps to reproduce:

from turtle import *
turtle = Turtle()
turtle.forward(10)
# RUN IT - NOT WORK

Bug appears at this link:

Browser:
OS:
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Replit Core):

Hey @WilsonPaul1!

Can you provide a link to your Repl so I can take a closer look? Is there an error that is being produced, if so could you share a picture of it?

https://replit.com/@WilsonPaul/StaticDeepskyblueOpentracker

@WilsonPaul1 is it private? I get a 404 error when I open it, could you provide your full code here or make your Repl public if you would like?

If it does not work, delete the output tab and look in the bottom-left corner of your screen, there you can scroll until you find this:
image
click on output and hopefully it will work,(if it isnt called output, just click on the one with the same icon :sweat_smile:), hope this helps!

Its public now. And all the code is in the ticket already:

from turtle import *
turtle = Turtle()
turtle.forward(10)

@WilsonPaul1 I see your problem, make sure to add an input() (it can be blank it just waits until you press Enter to end your program) to the end of your code to keep the output open. I hope this helps!

That is not the problem. The code is fine - it is ReplIt that is not showing the output correctly.

Btw, I did just test adding an input before responding. But this is basic turtle code - there is nothing wrong with the code. This same problem happens every month or so with ReplIt. Frustrating as a teacher with students not being able to see their code run one day that worked fine the day before!

@WilsonPaul1 so once you run your code what happens? Does the Output tab not show up at all, or something else?

Did you have your code like this? →

from turtle import *
turtle = Turtle()
turtle.forward(10) 
input()

I’m not asking for code help - the code is fine.
I am reporting a BUG for ReplIt here - they see this same issue frequently!

@WilsonPaul1 ok, doesn’t the Output tab show up at all, or does something else happen. If it doesn’t happen at all try what @CoolKid111 said.

The Output tab shows - but it has an error because ReplIt has a bug. Again, this is not a request for any type of help - it is a BUG report. I have many turtle ReplIts that all worked yesterday and none do now. This is just an easy example to demo the bug.

@WilsonPaul1 well can you share the error it is telling you?

There was an error connecting to the server

Again, this is a BUG report - no user can fix this issue and it is one that unfortunately seems to happen too often that replit should know how to address as they do it all the time.

you cold try changing this

from turtle import *
turtle = Turtle()
turtle.forward(10)
# RUN IT - NOT WORK

to this

import turtle as tt  *
t = tt()
turtle.bgcolor('black')
tt.penup()
turtle.forward(10)

No, this code is very buggy.


@WilsonPaul1 what is the full error you are getting?

I forked and there are no errors.

2 Likes

Yep, today a fork works for me too. Yesterday it did not. ReplIt clearly did fix something. But lately they never really provide any updates on what is broken and what they fix, nor do they respond to emails.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.