Python Turtle Loading Issues (Dec 2022)

Derrick -

I just introduced Turtle graphics to my students today in class. This is my first time teaching it.

I had them create a normal Python language repl (as they have been using for all of their text-based Python work), and then use this code:

from turtle import *
setup(480, 360)

For most of the students, this worked without any problem. But a couple of the students had the endless spinner in the output window, and never saw the turtle graphics window start up.

In at least one case, we were able to unblock the student by having her sign in to Replit on a different computer.

All of the computers (those where it worked, and those where it didn’t) are connected to the same network in the classroom, so I’m puzzled as to what might have been blocking it on some students’ computers, but not others. Could it be a firewall setting unique to those computers?

I will have them try the Python Turtle language instead, and see if that resolves the issue. But I’m still curious about the underlying cause. I’m concerned that this problem may rear its head again later in the school year, when we begin trying to use pygame.

I’ve tried following the workaround suggested in this thread: using the Python (with Turtle) template. But I still have a few students for whom the turtle graphics window never loads. For other students in the class, the turtle graphics are loading correctly.

All of the students’ computers (those that work and those that do not) are connected to the same school network.

Do you have any thoughts on what might be preventing it from working on some computers? Is there a firewall setting that might be specific to each computer?

These computers have their network settings centrally managed by the school district’s IT department. So the firewall on each of them should be configured the same.

Is there anything else that might be blocking turtle graphics?

I just want to make sure I’m clear on this: If a repl uses the Python (with Turtle) template, then the VNC protocol is not involved? Is that correct?

I don’t want to send our IT support people chasing after red herrings as they help me try to resolve this.

Hi @johnels Turtle problems seem - in the majority of cases - to be due to filtering within school networks. However I understand this is very difficult to troubleshoot.

My first suggestion would be to try to access the same Repl outside of the network. For example using a 4G hotspot or trying the same link at home or on a network where there are less restrictions. If it works in this situation then you can reassure your IT support team that there is definitely something being blocked that shouldn’t be.

I’m not sure if you have found the IT administrators toolkit doc on Replit? If not this is a really useful document to share with your IT support team.

Edit: As you had replied to a 14 month old topic I have moved your messages into its own new topic, as well as moving this into bug reports for the time being

Ian -

Thanks for your reply.

I accessed the student’s Repl from my computer, outside the school’s network (I am a remote teacher, so I’m not on the school’s network). It worked OK. It also worked OK from some of the other computers that are on the same school network.

The issue does not seem to be a browser configuration problem, as we tried it with two different browsers (Chrome and Edge) on the same computer, with the same results in each browser.

Yes, I had found the IT administrators toolkit. My guess is that VNC is somehow being blocked. Though why it would be blocked on some of the school’s computers and not others, I cannot say. I expected that they would all have identical network and firewall configurations, but perhaps not. If we really think VNC is the issue, we will file a support ticket with the school district’s IT department. (Though school is out for the holiday break now, so it may not get any attention until January.)

But in a reply to the original thread, Derrick said that a Python Turtle repl would not be blocked because it translates the turtle commands to Javascript, which I took to mean it did not rely on VNC. Perhaps I am misunderstanding?


Hi @johnels thanks for your reply and sorry for the slight delay in getting back to you.

I wondered if you could check the following URL on the computers where it appears the VNC is being blocked?

If it displays the following the correct firewall settings should be in place.

If it displays something different please take a screenshot and upload it here.

1 Like

Thanks. School is out of session until the first week of January.

I am a remote teaching assistant, so I don’t have access to the classroom computers, but I will ask the onsite staff to check this as soon as possible.

1 Like

Hi @johnels just circling back to this topic. Did you manage to get any further with testing to see if anything was blocked at the school?