Python pycario installation failed

Yep another python package problem
This time with pycario anyone wanna help?
It says like this
Here is the link but it’s not gonna work
If any of you got any way to help me install the packages please help

1 Like

Full error as text please? We can barely see anything with the screenshot. Also, the command you ran would be helpful.

1 Like

Running your program throws an error about “mainm” not being installed. Also, you could try using replit’s Packager to install packages instead.

1 Like

That is just poetry, and not all packages are listed, + it is 3 times slower, so what they are doing if fine.

1 Like

It will (rarely, but sometimes) install some things that I have problems installing from shell. Could just be me though. (Tweaked my response a bit, I think it’s probably better that way)

The entire stuff, seems that the problem happens when it is installing pycario

What happens if you try to install it with replit’s packager? (I’m not certain this will fix it, but it’s worth a shot)

Well it shows the same error, just that it uses poetry and also without those fancy red color to highlight the error

Hmm. I’ll try installing it in one of my repls and see what I get.

add the required libraries via Nix: in Shell:

sed -i 's/];/\n  pkgs.pkg-config\n  &/' replit.nix

Well after I ran

And tried to pip install again I got a very very long traceback
Like it is too long the log can’t even memorise half of it


Yep it took me 21 screenshots to capture the entire log I can currently readable, and there is like half of the log being deleted cuz out of range
And yep it still failed, with more errors

1 Like