Python packages don't get installed, even after saying they got installed

Problem description:
Python packages not getting installed.

Expected behavior:
When I click “install” on a package in the Packages tab, it gets installed, the button changes to “Remove”, and I can use the package.

Actual behavior:
When I click “Install” on a package in the Packages tab on Replit, it seems to download the package for a bit, and also gives me a red popup saying “… installed.”

But then, in the same Packages tab, the package still doesn’t show as “Installed,” it just shows the same button as before: “Install.” I also checked the poetry file and it doesn’t mention the package at all.

When I try to install again the cycle above repeats.

I get the same problem for different packages, and have tried on different browsers and machines.

But if I use pip in the shell, it does work.

UPDATE: I tried to install Flask-Compress, using the Packages manager. After a loooong time, the console threw this error:

--> poetry add 'Flask-Compress 1.13'


  expected string or bytes-like object

  at venv/lib/python3.10/site-packages/poetry/core/utils/ in canonicalize_name
       23│ _canonicalize_regex = re.compile(r"[-_]+")
       26│ def canonicalize_name(name):  # type: (str) -> str
    →  27│     return _canonicalize_regex.sub("-", name).lower()
       30│ def module_name(name):  # type: (str) -> str
       31│     return canonicalize_name(name).replace(".", "_").replace("-", "_")
exit status 1

Replit: Package operation failed.

Steps to reproduce:
No idea what happened. It just stopped installing one day.

Bug appears at this link:

Tried both Firefox and Chrome, on MacOS Monterey as well as MacOS Catalina.

My repl is private, but here’s the link:

It’s private, so I can’t see it.

1 Like

Hey! I updated the description above with new info (from more experiments), does that help?

can you try going to shell and putting in pip install Flask-Compress?

Yes, like I said in the original post, that does work. But therein lies the bug!

1 Like

oh I see, let me do some testing

are you sure?

maybe try forking the repl

Hey! Looks like you misread my post, I said it does work :))

The problem is that it only works with pip, but not with the package manager (poetry)

1 Like

yeah pip tends to work better, if you would like you can mark mine as solved so future ppl know what to do