(Python) Packager configuration (disable import guessing) does not work in the cover page

The configuration to disable import guessing (basically the only thing that allows you to import a local main, model, or game module without errors) does not work on the cover page, even for the owner.

If you run the repl on its cover page, it ignores the configuration and will auto install some packages. (Currently, even if the names already exist.)
So, repls that use this configuration (very few since not many people know it or use it) may not work correctly or have long booting times.

Example repl (the code doesn’t use any packages):
https://replit.com/@NuclearPasta0/my-game-example
Can’t really run it for a while in the cover page, this affects one of my actual projects that uses a game folder :frowning: .

--> poetry add rapid-router
Using version ^5.16.4 for rapid-router

Updating dependencies
Resolving dependencies...

Package operations: 33 installs, 0 updates, 0 removals

Steps:
Create a repl, disable import guessing in .replit file using some configuration (make sure to reload the shell).
Import main, in any file. Run the repl in the editor, it works fine. Run the repl in the cover page, on any account, it will try to install git-python.

The packager configuration is supposed to work on the cover page.

1 Like