Python package problem after upgrading

Problem description:

Traceback (most recent call last):
  File "", line 3, in <module>
    from flask import Flask, jsonify, make_response, request
ModuleNotFoundError: No module named 'flask'

Expected behavior:
Until this bug and without any change to my code the python program worked quite well

Actual behavior:
It seems that i am unable to reinstall the flask package.

Steps to reproduce:

Bug appears at this link:


Hey @Yehia-Gehad-Moh welcome to the forums!

Thank you for your post and sorry that you are experiencing issues. However, the Replit support team may not be able to help you with this issue if you do not complete the template fields fully.

Without knowing the expected and actual behavior (screenshots are fine for this section) as well as the link to your Repl and the steps a member of the support team will need to follow to reproduce the error there won’t be much we can do to help you.

The more information you provide at the start, the easier it will be to identify if your bug report is an issue or a misunderstanding.


Hello, @MikaelFaujour I would, first of all, like to welcome you to the community. Then ask if you have messaged any of the people on the support team. I think that might work better than asking around Ask.

Disregard what I said @Firepup650 knows way more than I do so you should listen to him. Lol

hello, thank you for your help.

I have done a pip install flash and now the program starts. It is a good thing.
But I have a new problem, this is a web application and every request come back with a 404 error.
It is like if the request does not come to my code.
It comes after the nix upgrade.

Can you please provide a repl link so we can help you troubleshoot this issue easier?

1 Like

Yes he has helped a lot.
Thank you @Firepup650
Its true he is a great inspiration and I would love to be as knowledgeable as him and work for replit and help people all the time like him.
Thank you

Hi Firepup650, it appear that my code works now.
I miss something somewhere because i don’t understand what appends but my apps is running now.

Thank you for having a look at my problem.

If your issue is now resolved (even if it just resolved itself), please mark either your own post or whichever post you think helped you the most in solving this issue as the solution.

1 Like

You did it again :grinning:
see you are the best

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.