Python package help

Error: onnxruntime Python package not installed.

Description: I’m encountering the following error in my Replit project: ValueError: The onnxruntime python package is not installed. Please install it with 'pip install onnxruntime'. I’m unsure how to fix this.

Welcome to the community! :smile:

Try running the following commands in the shell (terminal) within your Repl:

poetry add onnxruntime
poetry add onnxruntime-gpu
2 Likes

runs the both command but when I import chromadb in my views.py getting this error
ValueError: The onnxruntime python package is not installed. Please install it with 'pip install onnxruntime'

and when I import onnxruntime getting an Issue with onnxruntime and libstdc++.so.6 in Replit Environment
pls help us to fix this

Try navigating to the packages tab in the bottom left under ‘Tools’ and in the packages tab searching onxxruntime and clicking install on the package when it comes up. This will automatically attempt to install the package and any Nix dependencies (by adding them to your replit.nix file).