Python Build Not Deploying

Question:
My python build will not deploy even though it runs just fine.

Repl link/Link to where the bug appears:
https://replit.com/@CraigFreeman1/AutomatedMetaWebScraper
Screenshots, links, or other helpful context:

Welcome to the forums, @CraigFreeman1!
What deployment type are you using? Autoscale or Reserved VM?

1 Like

Thank you!

Im using autoscale on this attempt, but I’ve tried both vm and autoscale and achieved the same result.

Autoscale would not work for a project that does not open a port. To run this program, you must use a Reserved VM. When configuring the VM, what do you put as the settings?

3 Likes

Ahh, ok! Thank you. I must learn how to open a port then.

Here are the vm build settings:

You do not need to open a port for your project. Deploy it on a Reserved VM and select “Background Worker”. See:

Ok! I’ll try that out.

Thank you!

1 Like

Hi again!

So I tried to build it with what you recommended. It took a while but I’m met with the deployment issue still.

This time, in the logs, it looks like it just tried to run my program over and over and over again until it cut out. Below are the logs, thanks for any additional help you can provide!

That looks like the expected result — you want it to run over and over again, correct?

Oh, no. The deployment fails just like with autoscale. The error it gives in the logs is: error=exec: already started

I should clarify. It fails on the 4th step: Promote

I’m honestly not sure. I’ll see if any other community members have any ideas.

1 Like

Sounds good! Thanks so much :pray:

Hi @CraigFreeman1 !
Could you send the contents of your .replit file?
Thanks!

Hi there Nate,

Ive included the link to the python code in the original post.

Best