Pygame repl never runs, loading spinner forever

Problem description:
I volunteer at an elementary school teaching python coding to 4th and 5th graders. I did the same thing last year and this all worked fine. This year however, after we all create our Pygame replits, most of us can never run them with the pre-inserted template code. All we get is a loading spinner. It works for a few kids, but it has rarely worked for me. To be clear - we are not making any code changes. Just trying to run the template.

We’re on Chromebooks on the school wifi. I do not think it is a hardware or wifi problem.

Replit seems to work better with the regular Python3 template. I think it is something specific with the Pygame templte.

Expected behavior:
The Pygame replits reliably runs the template code (no code changes from us).

Actual behavior:
We see a loading spinner and nothing runs.

Steps to reproduce:
Create a new Pygame replit. Run it. Note: I have tried now and I cannot reproduce it. But we have had this behavior for the fast 2 Fridays in a row.

Bug appears at this link:

School Chromebook

Hey @TaylorSteil!

I am sorry to hear that you are having issues!

Your school might be blocking Replit. You can use, which should work even with firewall restrictions. However, if it doesn’t, you must contact your school’s IT administrator and let them know that they need to unblock these domains:

Also, could you send me the links to the student’s copies of the Projects that aren’t working so we can take a look and ensure this isn’t an issue on our end?


This replit is not running. It’s stuck in spinning. It worked when I created it, then I made 1 code change, ran it again, and its stuck.

fyi @ShaneAtReplit ^^

is there a way to reboot the VM?

Entering kill 1 in the shell should do that :slight_smile:

1 Like

hi @TaylorSteil I forked your Repl and it ran without issue.


I really think that there has been a firewall change in your school to cause this issue. Are you able to test or get the IT administrators to unblock domains as suggested by @ShaneAtReplit ?


I am trying to run it in firewalled mode but it says I have to open it in firewall mode and I dont see any way to do that.

1 Like

I just want to confirm the network connectivity is the problem before I talk to the IT department here.

I don’t see anything in the replit firewalled docs that talks about “opening the replit in firewall mode” but that is what it is asking me to do when I try to open it… any idea? Do we just have to wait for the VM to shut down naturally?

The problem is that I’m about to leave the school now and won’t be able to work on this again until next Friday =(

Does this link help? MadeupEmbarrassedModularity - Replit

1 Like

Could you email the IT administrators your link and ask them to test it out in the meantime?

1 Like

@IanAtReplit that is what i was trying. for me i see:

You can’t join this Repl from Firewall Mode.

This Repl was started by someone not in Firewall Mode. If you would like to join, please do one of the following:

• Exit Firewall Mode.• Ask the creator to open this Repl in Firewall Mode.

1 Like

Ok, I’ll just ask the IT dept to verify. Thanks guys!

1 Like

Oh I understand. You have to log in via, go to your Repl and then fork it. Running the new fork should work as you will have created it in firewall mode.

1 Like

Just to close the loop here - school IT dept confirmed they had one of the replit domains blocked. I haven’t been back to test it yet but I assume we should be good now!

I did not think it was a network problem because initially when you load the replit, it works. You can run your code like once or twice. But eventually it breaks. I would have thought a network connectivity issue would have caused a complete failure.

Thanks for your help!