Public Repository not being recognized when I try to deploy

I’m wondering if I can get faster help from the community on this issue, although I have contacted Replit support as well.

I’m working on a static website, and have been for some years. I had it published 1 1/2 - 2 years ago with a custom domain that I purchased. My domain expired and it was no longer hosted anymore since Replit switched to deployment-based hosting.

I renewed my domain and am paying for it currently without even being able to host my site since I am having this issue with deploying my repl. Any help with this?


Here you can see that home.html does exist and should be able to be used as the public repository.

:wave: Welcome @topoftheorder!

When creating your deployment, did you set the root/public (I forgot) directory setting to /?

1 Like

I set it to /home.html

That’s a file, not a directory.

Set it to / for it to work.

2 Likes

But would that not then look for index.html?


I did / and this is what I got.

Rename your home.html file to index.html and try again.

3 Likes

Yes, that’s how most deploying services work.

1 Like