Program signal terminating at first cin

So I believe this might be a setting that got changed on my computer or browser as this doesn’t seem to be happening to people testing my code but the bug is as fallows:

When I run a program ( does not matter what program I run one with bug or fully function) the programs signal terminated when it hits the first cin statement.

It will print any cout statement before to the output screen, then it hits the cin statement, I can type anything but it will not appear on the screen and then I hit enter and it says “signal terminated” rather then continuing on with the code.

I am unsure how to reproduce this bug or if it would even be considered a bug as it does not happen on other devices ( I have had someone in another form look at some test code and my professor look at other samples). I believe I might have accidently changed some setting on either the browser or the computer to cause this.

Bug appears at this link: test program - Replit

Replit Profile:

Never seen this before. Which browser + OS are you using? Disable any browser extensions which can access the site so you see if there’s a culprit

I am usings Windows 11 and Edge browser, and as far as I know I have no extensions running on this browser. I have also tried through Crome and I get the same result.