Problem with Test Cases in Python

Problem description:
I am a teacher at Newton North High School in Newton, MA. I teach our intro computer programming class, and we have used replit for several years. While our projects change every year, we have some core assignments that have remained the same for the past few years. The test cases are not working properly for any of our assignments.

In fact, the test cases do not even seem to properly handle the inputs. Here are some screenshots from an early assignment. The code belowSHOULD pass all the test cases.

print("I'm going to find the sum of a numerical sequence of data you create.")
start = int(input("What integer would you like your sequence to start at?\n"))

stop = int(input("What integer would you like your sequence to stop at?\n"))

step = int(input("What integer would you like your sequence to step at?\n"))

sequence = list(range(start, stop, step))

sum_sequence = sum(sequence)

print(f'Your sequence: {sequence}, has a total sum of {sum_sequence}.')

The test cases provide inputs for each number to be used in the sequence, and the expected output is copied directly from the successful code run above.

The test case then fails, and the “results” screen indicates that no inputs were used in the program at all, with blank boxes for “actual output” and “difference.” So, it’s clear that the test cases are not triggering the inputs.

I tried making new test cases, editing older ones, etc. Nothing seems to be working. To be clear, these test cases worked perfectly last year for the exact same assignments, and I imagine that some issues have arisen due to the migration over to Nix.

I would appreciate any insight or support you can provide.

Expected behavior:
The code block above passes the test cases.

Actual behavior:
The code blocks do not pass the test cases, and the “actual output” and “difference” boxes are blank.

Steps to reproduce:
Create new replit.
Copy in code above.
Create test cases as described.
Run test cases.

Bug appears at this link:
https://firewalledreplit.com/@c1-23-intro-python-peritz/3a-Sequence-Sum#main.py

Browser: Chrome
OS: Windows 10
Device (Android, iOS, NA leave blank): Lenovo
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Hacker, Pro Plan):

1 Like

See solution here: I/O Tests not working for me

1 Like