Problem with deployment and package

Hello,
I have a big issue on my deployment on Reserved VM.
It worked perfectly until today where I wanted to redeploy.

Now during the deployment it says :

info: Created hosting layer - 2023-10-19T13:50:40Z
warning: no .dist-info directory found for win32-setctime - 2023-10-19T13:50:43Z
warning: no .dist-info directory found for mastodon-py - 2023-10-19T13:50:44Z
warning: no .dist-info directory found for python-magic-bin - 2023-10-19T13:50:44Z
info: Found python package paths - 2023-10-19T13:50:44Z

and when it tries to start it has issues with mastodon package.

starting up user application
exec [sh -c python3 main.py] error=exit status 1
ModuleNotFoundError: No module named 'mastodon'
    from mastodon import Mastodon
exec [sh -c python3 main.py] error=exit status 1

Of course I can run it and use it perfectly without deployment. It seems there are packages available on ‘dev’ but that don’t work on deployment …

mastodon module is available in .pythonlibs

What can I do ? thanks

Here is an example of this issue in a very small public repl :
https://replit.com/@fvillemin/mastotest

I can’t deploy it… while it works and I have correctly added boost package which installs mastodon module. (mastodon is in .pythonlibs)

info: Creating Autoscale service - 2023-10-19T14:24:35.576Z
Traceback (most recent call last):
    from mastodon import Mastodon
starting up user application
ModuleNotFoundError: No module named 'mastodon'
exec [python3 main.py] error=exit status 1
exec [python3 main.py] error=exit status 1
ModuleNotFoundError: No module named 'mastodon'

My main repl using mastodon worked 2 days ago, maybe something has changed somewhere in the deployment method ?

Can you please help ? @lincoln-replit @replitted
Thanks

I have studied a bit and i have discovered that even if “mastodon” is in the .pythonlibs folder, the pip list doesn’t show “mastodon” but only “Mastodon.py”

image

Maybe it’s the issue and deployment only copies modules that are in the pip list ?
That would be a new feature because it worked fine two days ago …

It looks like you are getting the Python package caching treatment even though you are not an explorer. We’ve rolled back the caching logic now. Please reload the page and try to deploy again, and let me know if it doesn’t work.

Yes it works now, thanks
What would be nice is to have a changelog somewhere because when things like that are happening, we don’t imagine about an issue on the solid deployment process of Repl and we try to change our modules, our packages, uninstalling, reinstalling to try to fix the issue before complaining on the forum … it makes too much wasted time for debugging because of a bad roll out … If i had seen a changelog talking about packages cache i would have made a forum post before losing two hours of debugging :slight_smile:

I think, many people have changed their process to use deployments and create more ‘professional’ applications. We must rely 100% on quality of deployments.

Thanks for your hard work

1 Like

That’s an interesting idea! I’ll bring that up with the team.

1 Like