Problem with custom domain


I am trying to connect a subdomain to a repl. I have followed the directions and it doesn’t seem to be working. Here is some relevant info:

  • the repl is at and the subdomain I am trying to connect is

  • I added the cname and txt records to my dns (using namecheap dns)

  • whatsmydns shows almost entire propagation (there are a couple that still haven’t lower on the list, but I don’t think that is the issue because of my next point)

  • when I go to my subdomain, it does show a replit page, but it’s the page that says “Run this Repl to see the results here.” and it is flagged as not secure (the repl is just html/css/js (just a placeholder for now) and works fine if you go directly to the repl url)

  • replit implies there is some problem: “Currently, your domain is either not returning any records, or something is getting in the way of our verification process.”

Any thoughts as to what might be going wrong? Admittedly, I have not waited a full 48 hours since setting this up, but it seems that DNS is propagating fine so the issue is elsewhere (unless I’m missing something). Also, I tried to include more screenshots of the above points I made, but I guess because it is my first post I am only allowed to include 1? Sorry about that - and please let me know if any more info would help.

Many thanks!

Hello and welcome to the Replit Asl community, @ArshanGailus! I have solved this problem before. Currently, Replit’s custom domain linking is finicky. To fix this, I have a method that runs through github to connect the custom domain. If you’d like this method, just tell me.

Hey @ArshanGailus!

It looks like your domain has both an A and a CNAME record but no TXT record. Please take a look at:

@ShaneAtReplit Ah, that’s odd. I did add the txt record but now I see it does not show up on whatsmydns… So I guess this is a problem for DNS host. I’ll look into it on that end. Thanks!

@RedCoder - thanks for the reply and the offer. It looks like there may be a DNS issue afterall, so I’m going to try to fix it on that end first and see where I can get.

In my experience, I’ve seen that when you connect a custom domain, Replit tends to just say “Run this repl to see the results”. If this occurs on your end, I’m happy to share my solution

Hello @RedCoder ,

I am seeing “Run this Repl to see the results here” after linking to a custom domain. Please share your solution.

Basically, I have found Replit’s custom domain system to be rather finicky. My particular solution to this is to use GitHub Pages. If you would like me to elaborate, feel free to ask!

I have much better results when using A records for the domain. If Replit doesn’t allow you to select an A, do a DNS lookup on their CNAME, and use that. Occasionally the IP associated with the CNAME will change, and you’ll have to fix the A.

1 Like

Hey @LMMoore!

Have you checked out my response above?

I am not sure which “response above” you are referring to. I am using A record and TXT record. I do not have a CNAME record. Were you able to see on

Thank you for your assistance.

This was the response Shane was referring to:

Check that your A is still correct. Run a DNS lookup on the CNAME Replit gives you, assuming you can’t select an A.

1 Like