Problem with ai tool

Problem description:
When I click on ai tool to help me correct my code the different tabs(eg. Main window, console, output,etc) behave weirdly

Expected behavior:

Actual behavior:
The two tabs, one ai tab, and the tab beside it appear half. Means half of ai tab and half of other tab is displayed. Then the whole screen is glitched. Every tab is only half displayed

Steps to reproduce:

Bug appears at this link:

Browser:
OS:
Device (Android, iOS, NA leave blank):
Desktop app version (Avatar menu->“Version”) or NA:
Plan (Free, Replit Core):

1 Like

Can you send us a screenshot of the problem?

1 Like

The bug solves when i start typing from a new line in my document. And this bug is common to both app and website. The dark themed are website’s and light ones are app’s. (I would have sent more screenshots but new users can’t send more than one)

Ah, that should fix itself if you swipe to the far right panel, and then go back to whatever you need to do.

Thanks for your time. I appreciate that. But is there any permanent solution for that

No, I’m afraid there isn’t. The mobile app is buggy and has lots of similar bug reports made. The staff don’t respond on many of them, but they may be working on a fix. Or maybe not.

dw, they’re working on a fix soon :tm: , maybe later, maybe never, who knows? I personally find that keeping your tabs to the far right can be helpful in quickly swiping all the way to the right.

1 Like

Thank you all for help

I can look into it with my team if they don’t have in their backlog already. Do you have a consistent reproduction? Also, I’m guessing this is a mobile device bug?

The workarounds are appreciated, but if I have a good reproduction, we can most likely look into a fix. I have an Android with the latest Replit app version and I’m not sure I’ve ever encountered it.

It doesn’t always happen, but it does occasionally. It’s not a one-time bug that can’t be reproduced. I myself have experienced it multiple times. The fix I use is to exit the repl and go back.

Understood. I wish I knew what the trigger was for it. It’s harder to fix intermittent issues, but I’ll note it to the team if we see it happen again.

1 Like

I do get it all the time. May be its because I am using mobile as you said.
But i have found a temporary solution to solve it. If i scroll to last tab it fixs itself

@anita20062008 May I ask what mobile device you are using? Any specifications you can provide on it would be helpful.

I am using realme 6, 6 GB ram, octa core processor