Problem when importing from Freecodecamp Github

Hi, I 'm kinda new to replit so I gonna try to be as clearly as possible.
I’m trying to solve the Freecodecamp’s Scientific Computing with Python Certification, actually i’m having a problem using their starter code, for the arithmetic formatter, when i create the repl importing it from Github.
I choose the as the entrypoint, which was fine when I solved the time calculator for example. When I run the code the console shows “ModuleNotFoundError: No module named ‘pytest’”
Don’t know what to do, what should change in the configuration to solve the problem.
The link to this my repl.
I’d appreciate any help.

Hey, welcome to Ask (and Replit.) Mark an answer as “Solution.”

I created a fork and I ran this in shell.

pip install pytest
That solves your error, but I think there may be more errors in the repl.

1 Like

Adding on to @doxr’s answer, you could also run poetry add pytest in the shell if you’d prefer.


Thanks both @doxr and @Firepup650 for help me. I hope that no more errors show up.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.