Prevent flet-pyodide from installing

I’m getting

ModuleNotFoundError: No module named ‘flet_js’

and it seems to be due to flet-pyodide being installed.

I’ve done this in my main.py:

import flet as ft #upm package(flet)

And this is the top of my .replit:

entrypoint = "main.py"
modules = ["python-3.10:v18-20230807-322e88b"]

[packager.features]
disableGuessImports = true
disableInstallBeforeRun = true

And I’ve removed the package. Over and over again. But it persists and my project won’t run. What is the proper method to stopping this from loading?

Try doing poetry remove flet-pyodide in the Shell, then kill 1 for good measure.

1 Like

The configuration options you added are not supposed to be under a section [packager.features]. Remove that line, refresh, and it should work.

4 Likes

Thank you both for the responses.
flet-pyodide is no longer running… but I still get the same error (so it wasn’t pyodide necessarily?) Perhaps a new thread is necessary, but here it is.

Traceback (most recent call last):
  File "/home/runner/jawwj/main.py", line 2, in <module>
    import flet as ft 
  File "/home/runner/jawwj/.pythonlibs/lib/python3.10/site-packages/flet/__init__.py", line 1, in <module>
    from flet.flet import app, app_async
  File "/home/runner/jawwj/.pythonlibs/lib/python3.10/site-packages/flet/flet.py", line 5, in <module>
    import flet_js
ModuleNotFoundError: No module named 'flet_js'

If you run poetry add flet does that fix it? If not, how about poetry add flet_js?

When I poetry add flet:

The following packages are already present in the pyproject.toml and will be skipped:

  • flet

When I poetry add flet_js:

Could not find a matching version of package flet_js

Perhaps try removing flet and adding it back? It shouldn’t be missing it’s dependencies.

No luck there either.
I created a new project with a single line:

import flet as ft

And it also fails with the same message.

looks like the install process had been disrupted. Ensure that you don’t close the workspace while an install is happening. Or it could have been a temporary outage which disconnected you :person_shrugging:
Run in Shell:

pip install --force-reinstall flet

Had to force reinstall flet:

pip install --force-reinstall flet
1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.