Poetry version is too old in python repl - needs update

Can you please install by default more modern version of the package manager Poetry in python repls?

You have 1.1.13, the latest is 1.3.2. Syntax of poetry.lock isn’t compatible between versions.

I developed a telegram bot with python on my laptop under poetry version 1.3.2 and tried to run it on replit. Poetry failed to install dependencies because my poetry.lock wasn’t compatible with the old poetry version installed on repl.


Hey @alparo, welcome to the forums!

I’m sure Replit will update the poetry.lock file, but minewhile you can update is yourself using the shell, just put these commands on the shell :

  1. poetry update
  2. poetry update poetry==1.3.2
  3. poetry lock

@hugoondev Thanks for the suggestion! But it didn’t help

~/git-repl-test-1$ poetry update
Updating dependencies
Resolving dependencies... (17.2s)

Writing lock file

Package operations: 3 installs, 6 updates, 1 removal


~/git-repl-test-1$ poetry update poetry==1.3.2
Updating dependencies
Resolving dependencies... (1.0s)

No dependencies to install or update
~/git-repl-test-1$ poetry --version
Poetry version 1.1.13
~/git-repl-test-1$ poetry lock
Updating dependencies
Resolving dependencies... (3.8s)
~/git-repl-test-1$ poetry --version
Poetry version 1.1.13
1 Like


pip install poetry -U

I don’t know why poetry does not update itself, but that should work.
Note: you can always create your own template.


@dragonhunter1 thank you! It did the trick!
still would be good to have it in the default python repl. So I don’t know if I should mark your comment as solution.

I have never created my own templates. If it is a possible solution, then I should consider learning about them more.

1 Like