I have a python program that uses Python 3.8. I may have added Pandas later after initial development. When I click to run the app now, the console displays:
--> poetry add pandas Using version ^2.1.2 for pandas Updating dependencies Resolving dependencies... SolverProblemError The current project's Python requirement (>=3.8.0,<3.9) is not compatible with some of the required packages Python requirement: - pandas requires Python >=3.9, so it will not be satisfied for Python >=3.8.0,<3.9 Because pandas (2.1.2) requires Python >=3.9 and no versions of pandas match >2.1.2,<3.0.0, pandas is forbidden. So, because python-template depends on pandas (^2.1.2), version solving failed.....
This runs displays every time I run the app now.
If I check the poetry.lock file it says:
[[package]] name = "pandas" version = "1.4.4" description = "Powerful data structures for data analysis, time series, and statistics" category = "main" optional = false python-versions = ">=3.8"
This is not the version of Pandas that my console says it is trying to use when I run my app, as it says,
--> poetry add pandas Using version ^2.1.2 for pandas
My question is as to how to get this error message to go away. Ideally I want to use a version of Pandas compatible with Python 3.8 and stop this Poetry add pandas error from showing up each time I run my app. I suppose another option if possible would be to upgrade the repl to Python 3.9 if that is possible. Any insight appreciated.
pandas = "1.4.4" to the pyproject.toml file under
[tool.poetry.dependencies] and it made the console poetry error go away, however… If I check my Packages tab it does not list Pandas as being installed. Is Pandas installed? Did I solve the problem or did I just do something to make the error invisible?