"Poetry" and Nix are both not working

Bug description:
Have a flask application. Console has stopped working: it tries to execute “poetry add app” and ends with an error, Replit: Package operation failed.

Expected vs Current Behavior:
Running the console should just run the flask app as it always does.

Steps to reproduce:
I tried to install nodejs via Nix (as per the documentation, and everthing stopped working. I removed the entry from the replit.nix file, and now the console log doesn’t work.

Screenshot(s)/Screen Recording:

Browser/OS/Device: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:109.0) Gecko/20100101 Firefox/117.0

Replit Profile: https://replit.com/@mngrwl

Could you provide a link to a Repl where you can reproduce this issue?

1 Like

Hey Matt! Sure. It’s a private Repl so only Replit staff may not be able to see it: https://replit.com/@mngrwl/DLResurrect

Could you create another public one that demonstrates how you can redproduce this issue? Keep in mind, there are very only a few staff and a very large number of people asking for help, if the community can solve your issue it will get solved much faster than if you wait for a staff member to assist.

2 Likes

Sure, I created this repl: https://replit.com/@mngrwl/DLBuggy

It seems to be working right now, but it’s very unpredictable. And there’s definitely something wrong with poetry — it tries “poetry add app” on the console but it keeps throwing an error (that disappears immediately)

Could you run poetry add app in the Shell, and give us the output?

Run this command in the shell:

pip install poetry -U

This takes a while. Then, I think poetry updates all your packages to newer versions which also takes a lot of time.

I’d recommend to also open the hidden file .replit and change guessImports to false so that it doesn’t try to install a random unrelated package app.

2 Likes