Poetry add issue

Question: I am coding an online version of a table top game and for some reason now whenever i run the code, it shows a “–> poetry add” line at the start. The code after that works perfectly but is there anyway i can get rid of this because it slows down the process of testing

Repl link/Link to where the bug appears: https://replit.com/@JaptejMann/V96-C#main.py

Screenshots, links, or other helpful context:

code snippet
I have no clue where this aligns to cause my friend does all the main coding while i do testing, bug fixing and idea generation but pls help anyone who can

Hi @MitenPatel1 , welcome to the forums!
Are the packages weapon and colour even valid?

Hi @MitenPatel1 !
It appears that after trying to install the files (error), the program works fine. To remove the ppetry add line, go to the Files sidebar, click on the 3 dots, press Show Hidden Files. Then, go to the .replit file and enter the line disableGuessImports = true below the entrypoint line.
Hope this helps!

1 Like

Hey @NateDhaliwal,
Thank you so much but i just gotta ask before i mark this as closed, will there be any downside / side effect of this on the code??
Please let me know,

No. This will not affect the operation of your code. disableGuessImports = true disables the automatic installation of libraries when starting the repl. Your code will work exactly as it worked before.

@KAlexK so why does the code do that in the first place then? Is there any benefit of keeping it on??

Libraries are automatically installed for your convenience so that you don’t have to install all the libraries you need manually. But sometimes this system crashes and gives errors. Therefore, it sometimes has to be disabled using disableGuessImports = true.

If it bothers you or gives you errors, you can disable it. This only provides protection against wasting time on unnecessary installation of libraries and unexpected import errors.

1 Like

Alright thanks @KAlexK and @NateDhaliwal for your support, i really appreciate it.
Good Day too you all!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.